Question

Intune App overwriting asset tag with device name

  • 14 June 2024
  • 6 replies
  • 57 views

Userlevel 6
Badge +12

So this isn’t making sense to me, but since nobody else has mentioned it I have to assume I’m overlooking something.

We previously set up the Intune app to only create devices and update custom fields, just so we could get them pulled in. Like so:

 

 

Yesterday, I checked the “Update Asset” box to update the asset and custom fields so that we’re pulling in current usage data, etc. Shown here:

 

That setting alone is causing the Asset Tag field in iiQ to be overwritten with the Device Name from Intune. So lucky me, I’ve successfully erased about 10k asset tags. We can work through that though…

 

I don’t see anywhere in the options that suggests the device name is mapped to the asset tag field, and nothing in this guide mentions it either.

 

I even tried manually setting the asset tag on one device again, and then ran a full sync again, thinking it was maybe a one-time thing… nope. Overwritten again.

Intune doesn’t have an asset tag field that I can load these to and map in iiQ, so I don’t know how else we’re supposed to keep our asset tags attached to them in iiQ.

Is this a bug or expected behavior? If it’s expected… WHY???


6 replies

Userlevel 7
Badge +13

@jclark Thank you for submitting your question to our community! 😄

I am looking into this, but I have reached out for some additional assistance. Did you submit a support ticket on this? If so, what is the ticket number? 

Userlevel 6
Badge +12

I did not, because I’m assuming this is how it was designed - that’s usually the answer I get lol.

I am looking into a workaround right now, but still curious is that’s expected behavior or not.

Userlevel 7
Badge +13

@jclark It was confirmed this is functioning as intended—however, a possible workaround. If you uncheck the updated asset, you will be given the update custom field option to select. This will update only the custom field instead of the asset tag. I hope this helps. 

 

Userlevel 2
Badge +3

I did not, because I’m assuming this is how it was designed - that’s usually the answer I get lol.

I am looking into a workaround right now, but still curious is that’s expected behavior or not.

@jclark what do you have in your Data Mapping set to for the Asset Tag?

 

Userlevel 6
Badge +12

I did not, because I’m assuming this is how it was designed - that’s usually the answer I get lol.

I am looking into a workaround right now, but still curious is that’s expected behavior or not.

@jclark what do you have in your Data Mapping set to for the Asset Tag?

 

@akorkishko 

Since we have several connections for assets (Jamf, Google, Intune, SCCM) we don’t have anything set there. That just chooses an app that takes first priority when mapping, but doesn’t stop it otherwise.

@jclark It was confirmed this is functioning as intended—however, a possible workaround. If you uncheck the updated asset, you will be given the update custom field option to select. This will update only the custom field instead of the asset tag. I hope this helps. 

 

@Kathryn Carter I appreciate the response - I did state originally that we were doing that previously, but none of the metadata was being updated that way. It doesn’t make sense to me that there’s no way to stop the device name from mapping to the asset tag field, and it’s also not documented anywhere.

As a workaround, we are going to try mapping the asset tags to the “ManagedDeviceName” in Intune, which is a separate field from the “Device Name”. This is going to take some time, though.

Userlevel 7
Badge +13

@jclark Yes I understand how this would be confusing. Please let me know if adjusting the name mapping helps! 

Reply